Video playback freeze even on jit.movie help patch with Win10 64 + GTX 960


    Mar 11 2017 | 6:38 pm
    Hey there,
    I'm pulling my hair out getting the most basic video playback on a brand new PC and Max installation.
    We use a brand ZOTAC enMagnus 1060 (featuring Nvidia GTX 1060) with Win10 64 bits. Both Windows and Nvidia drivers are up-to-date. Even when just using the jit.movie.maxhelp patch, I can't have a smooth playback (or playback at all).
    With viddll: - even using blading.mov, video plays smooth for about 2secs, then stops. When the loop starts over, the same 2secs will play smooth, then stop at the exact same point. Interesting fact: If I jump to another point anywhere in the video with the playbar, I will get 2secs of smooth playback from there and then freeze again. - same results with other videos, including the HD one used for the installation, except that the freeze happens earlier. So I suspect it may be related to some cache getting full faster? - so I tried increasing the cache_size attribute, with no impact at all
    With QT: - blading.mov seems to play well in full, but with higher res video, the playback is stuttery as hell and unusable.
    Outside of Max: Videos run as expected in any of Windows default players. They also run much smoother in QT Player than in Max with qt engine.
    I'm using the latest version of Max (7.3.3) and tried both 32 and 64 bits with same results.
    In the Nvidia control panel, only the GTX is showing in the CUDA processors (no integrated chipset, I even disabled it in the BIOS), and in their taskbar processor utility I see Max as assigned/running on the GPU properly. In Windows, any power/performance settings are set to "maximum performance".
    In the same software configuration (Win10 64bits + Max 7.3.3 64bits) on my MSI GT72 laptop (Nvidia GTX 980M) I have no problem at all.
    I'm just totally lost at what/where I could check or tweak to hope identifying and fixing the problem. The ZOTAC is supposed to be a BEAST and it is, when pushing it to its limits on the most GPU intensive vvvv patches I have. I just don't get what could be limiting or supsect in something as basic the video help patch with Max.
    We have TWO of these ZOTACs in the exact same software configuration and we have the exact same results, so I guess there IS something I am missing, OR a real bug identified here.
    Any suggestions on what I could try to further investigate? or similar expériences with a magic fix?
    Thanks for your ideas guys! T

    • Mar 13 2017 | 8:21 pm
      can you try the following patch and see if it plays as expected?
    • Mar 15 2017 | 1:22 pm
      Hi Rob,
      Thanks for reaching back!
      I just tried the provided patch, but get the exact same results. I base my tests on the blading.mov video and the video provided by the client for preview. With chickens.mov it's hard to tell because the last part of the video is static so it may freeze or not on the last frames...
      Let me know if there's anything else I can test or try. I'm on site today and tomorrow, and the installation has to leave at the end of the day tomorrow (Paris time)... :/
      Thanks for your help! Thomas
    • Mar 20 2017 | 7:55 pm
      hard to say, but increasing the cache_size may help. make sure you're running in 64 bit mode so you can access all available memory