Can't save qlist in standalone application?


    Aug 09 2018 | 8:34 pm
    Hi all,
    I'm building a standalone where users should be able to modify and save a qlist. The only problem is, the save option is disabled when I build the application into a standalone.
    Does anyone know if there is a way to enable qlist save for applications?

    • Aug 10 2018 | 7:41 am
      using write opens save dialog, using write with full path saves also without problem, standalone or not ... Having a file name as argument inserts the name in save dialog ... OSX, max 6.1.10
    • Aug 12 2018 | 4:28 pm
      Hey Source Audio,
      It's interesting that it works for you, but I'm definitely not getting that result. I built a standalone with three objects: a qlist, and two messages attached to it: a message that says 'write' and a message that says 'read'.
      I run the standalone, open my blank qlist, and type two lines of code:
      this is a test;
      0;
      When I attempt to close the editor screen, I am prompted with two options "don't save" and 'cancel". The 'save' option is greyed out. So I close the editor window, which obviously clears out the content.
      Next, I click the 'write' message, the one that is connected to qlist. This is successful in bringing up the "save as..." dialogue window, and I title the empty file as 'test.txt', and choose to save it to the desktop. Hey, this works! I've created a blank document named test.
      However, when I open up the editor and add the test content, I get the same result as before... When I close the document I get the choices of "don't save' or cancel.
      I try something else. Without closing the editor, which now has two lines of code in it, I go into the patch and hit the 'write' button. I get the save as prompt and I name the file 'test2.txt'
      Test2.txt is also empty. The items in the qlist do not become set until I save it from within the qlist.
      So, I try one more thing. I have the qlist open, it has it's two lines of code in it, and I go to the dropdown menu for the standalone. From here, I can select 'save', and it saves. It actually saves.
      It seems like this MUST be an error on C74's part. Why would you make it so that only one of three methods of saving works? Its like they meant none of the methods to work, then changed their mind and decided they DID want app users to save, and forgot to update the other save functions. OR, they had the ability to save then decided to remove it, and forgot to remove that one method of saving.
      Either way, this is screwy and it doesn't seem appropriate. Another funky thing is that if I decide to make my own custom menu and I decide to overright the 'save' menu item, there is no way to get the save menu item to save the qlist. So, in this scenerio (which IS my scenario in my app), there is simply NO way for users to save their qlist documents.
      And the most frustrating part is that there is no documentation of this scenario or this issue in the C74 documentation. I suppose it's time to file a bug report.
      For the record, this is in the latest version of Max 7, and the behavior is consistent on both the most up-to-date version of Windows 10 and on MacOS High Sierra.
    • Aug 12 2018 | 4:56 pm
      qlist is not my favorite for any kind of storage... But back to the saving - qlist does not have option as coll to embed contents into patcher or not, it just does so. when one saves the patch. As standalone is not editable, saving of qlist contents in a patcher is not possible. That's why it is grayed out. Saving to hard disk is possible
    • Aug 12 2018 | 5:23 pm
      I'm not really talking about embedding though, which isn't a concern in this scenario. Saving to hard disk is only possible via one of three methods offered in the code version. This isn't documented and it's not explained. This is clearly an oversight on C74s part, and I can't imagine they would intentionally be so inconsistent and opaque.