Cannot connect ROLI Lightpad M to BLOCKS package objects


    Dec 21 2017 | 7:38 pm
    Hey there!
    Just bought a ROLI Lightpad M and cannot connect it to Max Blocks object from the ROLI Blocks package. - I downloaded the Blocks Dashboard and updated firmware of the Lightpad to 0.4.2 - I downloaded the latest Blocks package in Package Manager - my Max 7 is up to date (7.3.4 64bit on Win10) - the block is connected over USB, and does charging properly If I use the Blocks Dashboard all communications seem fine: it does show finger touches in real-time, I can update the pad's mode etc. But in Max, whatever object or help file that I open will say "not connected to any block". I do verify that the midiout object points to the proper MIDI port of the Lightpad. In MIDI tester I do see MIDI input from the Lightpad properly. Same if I put a "midiin" node with a "mpeparse", I see all the data coming in properly.
    But all "native" Roli objects from the official Blocks package are broken for me.
    I can't find any similar connection issues on the forum.
    Thanks for your help! Thomas

    • Dec 23 2017 | 8:32 am
      I am having this problem as well with a brand new Lightpad M. I can get midi information, but none of the gee-whiz golly-wow role lightpad related animations or visual feedback (and none of the Blocks patches work) I updated my lightpad firmware to the latest the first thing I did. I also used the Blocks app to play a bit. I was surprised I could not deselect anything on the blocks app. Has this hardcoded my lightpad to no longer work with max? I have two days left on my Max trial (earlier issue with a dead lightpad) and I would like to use the software during those final two days.
    • Dec 23 2017 | 3:31 pm
      Hey Gerry It seems the Lightpad M introduces a few changes in how it communicates with Max, compared with the original Lightpad. In parallel to my original post here I used the "Report a problem with this package" from the pack screen, and the support team replied to me with a link to their current Beta package for the Lightpad M, which does work for me, apart from a couple of minor bugs they warned be about. You can probably get access to it as well if you request it to the support team! Hope this helps, T
    • Dec 24 2017 | 4:52 am
      Thank you. they were kind enough to provide me with a copy as well, and I have been trying to play with it.
    • Dec 30 2017 | 6:32 pm
      Help! I am having the same trouble!
    • Dec 31 2017 | 5:19 pm
      Carmen, read the above and follow Tremenss' advice.
    • Feb 16 2018 | 4:08 pm
      Hi! Does anyone know if this has been fixed yet? I'm experiencing the same problem.
    • Feb 16 2018 | 4:12 pm
      It has. Check the Package Manager for the update. What I don't recall has to do with whether firmware updates are necessary for the devices - I don't think so, but I could be wrong.
    • Feb 16 2018 | 4:44 pm
      This has been resolved. the latest version should be available on the Package Manager. I do still have some problems with a conflict between the Blocks package and another, but I am unsure which one is causing conflict. I uninstalled/reinstalled max (windows 10) and it resolved itself. I have had to do this a few times, and have just stopped downloading packages willy nilly without testing if Blocks still works between each package installation.
    • Feb 16 2018 | 10:48 pm
      Welp. The thing is that I actually just installed Max for the first time a couple of days ago, because I got 3 months for free when I bought the Lightpad. So the package I have installed should be the newest one. But maybe I'm doing something wrong - after all, as I said, I am completely new to Max.