Error in Max8 window: ad_asio: ASIO Stop() returned -997


    Nov 15 2018 | 8:44 am
    Hello Maxers. I get this errors messages in Max Window as soon as I launch MAX ad_asio: ASIO Stop() returned -997 when using my sound card
    ASIOCreateBuffers error -997 when using my default Alienware sound card
    I do not get these messages in the last version of Max 7.
    Hello, I am using Windows 10 and Max 8.01 ( the last Max version now). in an alienware computer. I am also using a RME 802 audio interface. All my Windows and soundcard drivers are up to date. Any ideas about how can I fix it?
    Thank you in advance.

    • Nov 15 2018 | 12:54 pm
      I haven't wirked with Windows/ASIO since many years, but does your sound cards work with other software? That it fails with both cards may hint to a system problem....
    • Nov 15 2018 | 1:14 pm
      Yes, they work fine with other software. I can use audio in Max, the only thing that I can not do is recording audio when I try to record my screen using GeForce Experience which is a software to record OpenGL graphics, i.e video games. ( I need to do this to record my Jitter performances).
      The same software (GeForce Experience) can record audio in Max7 and also in video games so I assume that the problem is not WIndows 10 or GeForce Experience . Since Max window is displaying an error it is possible that it will be the problem.
    • Nov 28 2018 | 1:27 pm
      Same here. Just dropped a mail to the support team, hopefully they will come up with a solution...
    • Jan 14 2019 | 2:34 pm
      I installed Max 8.0.3 and the bug is still there
    • Jan 17 2019 | 9:59 am
      I have the same error messages: ad_asio: ASIO Stop() returned -997 with the ZOOM UAC2 ad_asio: ASIO Stop() returned -1000 with the RME HDSPe Expresscard
    • Jan 17 2019 | 10:56 am
      Following, Im also having issues with ASIO and Max8. I'm not a regular Windows user, so I just thought it was a hardware issue.
    • Mar 06 2019 | 9:06 pm
      I have the same error message:
      ad_asio: ASIO Stop() returned -997 RME Babyface Pro Driver: ad_asio ASIO Fireface USB
      The issue also appears when I select ad_asio ASIO4ALL v2.
      It does not appear when I select ad_portaudio ASIO and select ASIO Fireface USB as my input.
    • Apr 28 2019 | 2:16 pm
      I've opened a support ticket, too - the problem with these ASIO error messages is, there is or has been no real reproduceable effect regarding audio processing so it's hard to trace it down. Maybe there is one now as described below.
      I've experienced the same restart problem with two complex standalone MAX applications - logelloop5 and MSDP2 running on Windows 10 1809: If I have my ASIO devices connected I can run the app only one time - if I close/quit I cannot restart the app until I restart the computer. A second attempt to start the app after having closed/quit the app results in a hang and within the Task Manager or Process Explorer it is visible that the app is not loading RAM anymore, not as much as during the first start. If I disconnect the ASIO devices and choose the ad_portaudio mme driver there is no such problem.
      The mentioned standalone applications are available for download. MSDP2 is free and the sources are available here: https://github.com/MusicSDP/source-code Because MSDP2 sources are available I was able to test it and the problem described above is existing in case of running the patch from the sources, too.
      To check if the ASIO Stop() error messages reported in this thread are related to the "restart problem" I've described it would be cool if some other ASIO device users which are experiencing the error messages this thread is about could check if they are having the same problem with e.g. MSDP2 or logelloop5. It would be also of interest if some ASIO device users not seeing the ASIO Stop() error messages are having the "restart problem", too. With the MSDP2 sources the "restart problem" exists only if the main patch and MAX is closed via the menu entry Exit, it does not exist if the button "Close this patch" is used. Cheers
    • May 02 2019 | 4:03 pm
      The runtime application restart problem is solved so far but MAX is still printing the error messages. I have reinstalled both ASIO drivers and I have selected on board HD Audio Device as the systems default audio device, instead of the UAC 2 or the RME. Thus even if these ASIO error messages are still printed to the MAX console both applications mentioned above are restarting just fine.
    • Jun 13 2019 | 7:08 am
      I have this same error in the latest version 806
    • Oct 07 2019 | 10:14 am
      Hi everyone, I have the same error message, with the lastest version (8.1). Does someone have a solution?
    • Dec 29 2019 | 2:28 pm
      Hi there. The same with me (I'm using a Sonic Core Scope PCI audio card).
    • Mar 14 2022 | 10:08 am
      Hi, I wonder if anyone found a solution to the problem ("ASIOCreateBuffers error -997").