HELP! Max crashes when moving hit.window between displays (windows)


    Apr 21 2019 | 2:17 am
    Hi guys,
    im having the problem that the max application crashes every time I move a jitter window between displays (almost, this happens 95 times out of 100) On my PC (Specs at the bottom).
    /* and this is making it really hard for me to do visual live performances using projectors */ (I don’t have this problem running the same patches on Mac, but my Mac can’t really handle very graphics heavy things).
    it doesn’t seem to matter what is in the window or if the context displayed in the window is being rendered. it also doesn’t matter if I drag the window/ assign it a position on the 2nd screen / assign it a position on the 2nd screen In a list followed by a fullscreen command etc. it seems to be working slightly better using the windows system shortcut for moving windows (windows icon + arrows) but I might just be imagening that. If I do manage to get the window to the secondary display everything works fine, and There is no problems toggling fullscreen on/off in the display the window is in.
    I didnt use to have this problem, but it showed up at one point within the last 6-months.
    Any ideas of what happens and how I can solve this? are there maybe some gl settings in Max I should change? Or Are there some graphics card settings that will do the trick? I‘ve been tearing my hair over this one for a while, and tried all I could think of, and using different graphics settings /resolutions etc. And I’m running out of ideas so any help or pointers etc would be greatly appreciated. thanks!
    — my machine is a Dell XPS 15 9560 x64 based PC
    windows 10 Pro intel i7-7700HQ CPU @ 2.80GHz (4 core, 8 logical processors) 32gb ram
    Nvidia GTX 1050 4GB GDDR5 Driver version 419.67
    DirectX runtime version 12

    • Apr 21 2019 | 2:18 am
      Jit.window not hit.window
    • Apr 22 2019 | 6:21 pm
      we've recently got some reports about this problem and will be investigating fixes. If it's the same issue, the culprit is differing display scaling settings on the two displays. you could either set the display scaling equal, or another work around is to make sure you position the window on the second display prior to enabling rendering. as long as the window is on the second display, and then rendering enabled for the first time, fullscreen should work.
      you can also rebuild the context after moving it to the second display, by toggling an attribute like border. hope this helps with the crashing for now, feel free to let me know if your experience is different.
    • May 31 2019 | 11:50 am
      Thanks for the answer, it does work better with setting all displays to have equal setting, but if rendering is toggled or not does not seem to matter.
    • Jun 01 2019 | 6:03 pm
      this will be fixed in the next update (8.0.6), thanks for the reports.