I seem to be encountering an error when connecting code to Inlets in gen~.


    May 31 2023 | 9:42 am
    I am currently studying gen~ and I'm facing an error that is difficult for me to understand. To provide a better explanation, I have recorded a video showing the error. It's a short video, so please take a look. https://drive.google.com/file/d/1lc32RH6YFv-1dY5SOiMCbHlqqJyMP5Jn/view?usp=sharing
    When I connect it to [out 5], no data is being outputted, but when I create a new [out 7] and connect it, data is being outputted. Similarly, when I connect the code from [* 60], no data is being outputted, but when I connect it from [out 5] instead, data is being outputted. What could be the problem? Also, when data is not being outputted, the color of the [out 5] inlet is not red.
    I'm not sure if the same error will occur on other computers, but I'm also uploading the patch along with it.
    maxpat 15.45 KB
    Thank you.

    • 👽R∆J∆ The Resident ∆lien👽's icon
      i'm unable to confirm the behavior with your same exact patch(i think that's because it's already created with everything in place, and so the dsp will compile properly from start)... but going by the video, it looks like you're able to return it to normal function eventually, this implies some problem with compilation upon initial creation of objects, so if you run into quirky behavior like this you could try restarting the audio engine, or possibly manually compiling(see the bottom toolbar within gen~, you can disable auto-compile then re-enable to force compile, or disable, then use the regular 'compile' button next to it(in which case you'll need to do that with every change you make thereafter until you re-enable auto-compile again))... but for every problem like this that i've run into(MC objects have had issues that could be solved like this, too), turning the DSP off and then back on again usually is enough to fix it(try that first).
      if you keep running into this strange behavior and can isolate the problem into reproducible steps, you can submit a ticket about it here: https://cycling74.com/support/contact
      hope it helps 🍻