Internal PortAudio error?


    Jul 10 2020 | 9:26 am
    Hi All~
    Have been using Max since the old Mac OS 9 days and have always used ad_portaudio Core Audio as my driver (mostly because some of my legacy apps require a 32kHz sampling rate). Fast forward to Max 8.1.5 on macOS 10.15.5 (Catalina) and, just today, I've begun receiving the following error...
    adportaudio_start: error Internal PortAudio error from portaudio opening stream
    ...whenever I try to start audio on my patches. I've checked my sampling rate, I/O & signal vector sizes, and everything looks the same as it ever was. Any ideas why ad_portaudio Core Audio would suddenly stop working for me?
    Cheers, ~Randy
    P.S. Have tried everything I can think of, rebooting my Mac, trashing the Cycling '74 folder in Library : Application Support, uninstalling and reinstalling Max, and still no joy from the ad_portaudio driver. :~(

    • Sep 22 2020 | 6:30 am
      Hey Randy,
      I'm not sure if you found a fix to this problem, but I ran into a similar problem a couple days ago with both Max and Purr Data (Pd-l2ork) which both can use ad_portaudio (although Max also lets me use Core Audio with my setup). Something I found which worked for me was to try creating a new user on my system in the group "Administrator." Once I logged into that user account and tried launching Max, I found that ad_portaudio started working again because the ~/Library/Audio folder was clean for that user. This might also take a reboot or two to work. If you determine the problem originates from the ~/Library/Audio folder, then you can debug some more and figure out which Component, Plug-In, or driver is creating the problem.
      Evan