Issues with cv.jit objects on Windows


    Jul 03 2022 | 11:28 am
    Hello,
    I found a few topics close to this one, but the latest have no answer.
    I'm having some issues with the cv.jit library on Windows. So I developed a patch on macOS and want to get on Windows so that I can export it as a standalone application for both platforms. On macOS everything is ok. The problem is when I put it on Windows. Max can't seem to find at least some objects, like the cv.jit.centroids (that I use quite a lot in that patch). I installed the externals and made Max look into the folder where they are, but I always get the Max console report that it couldn't find the object. The weirdest thing is that the message immediately after appears in blue saying that found the object in the cv.jit package, but it seems that is still not using it. I thought that the objects maybe had been built to Windows and to macOS and I was using the macOS one, but already tried a lot of things and it never works. Maybe I'm still using the macOS builds, but I'm really not sure what is happening. On the Windows machine, I'm running Windows 10. Max version is 8.3.1 (latest at this time).
    Does anyone have an idea of what am I doing wrong? Or does someone has experience using this library on Windows?
    Thanks in advance :)

    • Jul 05 2022 | 1:54 pm
      Sometimes I found that objects get stuck into "os mode". If you try to delete them and recreate them from scratch in your patch or in the help file, do they work?
    • Jul 05 2022 | 2:51 pm
      is this report related to breakage in the standalone build on Windows, or simply running the patch from Max on Windows?
    • Jul 05 2022 | 9:39 pm
      Thanks Federico! I also had that experience before so I though about it as one of the potential issues (I tried quite a few things), but no...it didn't seem to help. Or at least where/when I tried it. Rob, my goal is indeed to build the application for Windows, yet, this happens before that. So to answer you directly: simply running the patch from Max on Windows I find this issue.