jit.grab no audio devices found


    Apr 11 2019 | 12:31 pm
    Hello everyone, I am still pretty new Max user and i don't have a big knowledge yet. Anyhow, i wanted to make Mirror using my Integrated cam from laptop. I found many ways to make it, but everytime it seems like i need jit.dx.grab object to make it work and jit.dx.grab object then constantly shows 'no audio devices found'. I came to this problem while i was trying to build mirror application. Just simplest mirror. I just wanted to see how 'build application' works actally, but then i tried to open it to another computer and jit.dx.grab object was the only object which couldn't open, so application failed. I am Windows user, and i'm using Max 8, 64bit. I would really appreciate if someone please can tell me if and how it can be fixed OR if there is other way to make Mirror using some other object and not jit.dx.grab from above? Thanks.

    • Apr 12 2019 | 4:28 pm
      i've never encountered this error before.
      open up the jit.grab helpfile and click the "getvdevlist" message. what devices are listed in the vdevice menu (you can ignore the input menu)?
      try selecting one of those devices first and then opening the device. if there are more than 1 try each of them.
    • Apr 12 2019 | 8:05 pm
      Hey Rob, thanks so much for answer. I have three devices and each of them work fine, i get a picture of my cam everytime so it's okay. But - still whenever i click 'open' message i see in max console 'no audio devices found'. I am just trying to realize why it appears because obviously i do something wrong if i get that message everytime.
      However, i also tried to ignore it and build just for example 'jit.grab' application again, but when i did it and tried to play it on another computer, i got this:
      I have a lot of errors and jit.grab is totally out of function. What i miss? Could you maybe give me some hint how to start with fixing this step by step? I guess i am missing some files, but i don't know how to find them and which they actually are.
    • Apr 15 2019 | 4:19 pm
      distributing standalone applications on windows are another issue and unrelated to you jit.grab error messages. i'll see if i can track down where that message is coming from, but you'll just have to ignore it for now since it's not affecting functionality.
      search around the forum for the standalone on windows issues.
    • Apr 15 2019 | 9:11 pm
      i don't know, i still has problem 'error loading external 126' when i open my standalone application on another window, it's so weird. however, thank you so much for reply Rob, i appreciate it, i'll look around to ask people with similar problems about that. thanks