LibC++


    Aug 04 2019 | 11:46 pm
    I wanted to learn C++ from inside max so I created a .cpp file in my xcode file. Got an error talking about a deprecated c++ library (stdc++). the current is libc++. Here's the comment that fixed it. I'd just suggest someone run around the SDK and switch the xcode setting over.
    From: https://forums.developer.apple.com/thread/106114
    For anyone else encountering this issue, I was encountering it because one of my project's frameworks was still using the old "libstdc++" library which is now unsupported in Xcode 10. I had to go into the framework's Build Settings, scroll all the way down to "Apple Clang - Language -  C++" and change the C++ Standard Library from "libstdc++ (GNU C++ standard library)" to "libc++ (LLVM C++ standard library with C++11 support)"