Live Set Crash caused due to M4L Device - can't reopen project.


    Jun 01 2020 | 4:01 pm
    I was building a M4L device (a simple MIDI FX), and got it working just fine. I was able to restart the project and still have everything working so I added some automation to one or two parameters.
    I noticed that the undo history was stacking with loads of values, so I knew what was wrong and fixed it. Upon saving, Live proceeded to crash. So I opened the device in standalone Max to remove the offending object and save the patch. However, now Live refuses to load that one set. I have tried the following things: 1. I deleted Live's undo history 2. I redirected Live to the bundled version of Max 3. I entirely replaced the objects that may have been causing issues. Nothing has worked so far, so I seek any help that anyone may be able to provide. This is the device I was working on - It will load happily into other sets, and sets wont crash when it reopens. But on one particular set it will crash Live immediately.
    I can't tell whether I have patched something wrong (like maybe something is being initialised badly) or whether the issue is with Live. If anyone can help - or have similar experiences please let me know.
    Cheers! James
    P.S. I am assuming the crash is my Max Patch because the only other plugins opened were Spitfire Audio's Labs, AIRDiffuseDelay, 2 Ableton MIDI FX, and another M4L MIDI Device, all of which I use very frequently with 0 issues.

    • Jun 02 2020 | 2:55 am
      Two things I’ve had some success with in similar situations: 1) Find whatever folder is in your Max preferences for where your .amxd project files are being kept “Default Folder for Max for Live Device Projects”. Take everything there (at least related to your problem item) and move it aside into some other folder. That way Live won’t try to look for any files there that it might use instead of your new updated .amxd.
      2) With crashing/hanging-on-load sets I’ve had luck by making a DummyMIDI.amxd that is just midiin-midiout. Then I move problem_device.amxd aside, and put a copy of DummyMIDI.amxd in place of problem_device.amxd and try loading the set. This at least sanity-checks that there is at least SOME kind of surgery you could do to your device to isolate the problem.
    • Jun 03 2020 | 4:00 pm
      Thank you for the suggestions, I'll bear them in mind! I've fixed the issue by opening a new Live set, and just dragging the track into a new set from the old set folder. Seems to be working so far! Although I have no idea why it crashed in the first place, might anyone have any resources on the best practices for creating M4L devices? Patches that work in Max standalone have a tendency to crash Live.