Max's list of MIDI ports is not correct....


    Jan 10 2021 | 1:25 am
    I am experiencing a strange problem, possibly a bug. When i use a MIDI-object in Max and try to set a specific port, Max chooses a different port. Actually whatever port i choose, the software will choose a different one. So my guess is that the list of ports are incorrect. Any idea how to fix it?

    • Jan 10 2021 | 2:54 pm
      Post your patch.
    • Jan 10 2021 | 3:11 pm
      Thanks for answering. It's just the simplest possible test patch for debugging purposes, and guess it will not show my list of MIDI ports anyway. But here's the patch i've made.
    • Jan 10 2021 | 3:24 pm
      Try this:
      I ran into a similar problem (on MacOS) - hope, this trick works.
    • Jan 10 2021 | 3:47 pm
      Wow, this actually worked great and saved me a lot of frustration! Thanks a lot!!
    • Jan 10 2021 | 4:00 pm
      Haha... yeah, I’ve spend a day or two trying to find this workaround - I’m happy, it’s useful for others too.