Max 8.2 / Rosetta / non-functioning objects


    Oct 14 2021 | 5:23 pm
    I don't see a list of objects that don't load with 8.2, so I thought I'd start one, hoping that it will be useful for some and a prompt for others (hint hint). (i've tried this with 8.2 set to load natively, but the following list is of objects that fail to load (incorrect architecture) while running Max8.2 in Rosetta2. These are all objects that I use a lot.)
    fromascii and toascii (jasch objects / Package Manager) all of the string objects from jasch objects (I guess all of the jasch objects) mubu CNMAT externals (specifically OSC-route & list-interpolate) f0 objects imp objects (specifically imp.artnet.controller) zsa.descriptors (from the Packages installer) fluidsynth~ (I think this would be very difficult to replace with native objects, but I'm very happy to be proved wrong!) LObjects (I've replaced a lot of these with native objects, but there are some LObjects that are tricky to replace). ml.markov

    • Oct 14 2021 | 5:56 pm
      @DAVID So far all of the items I've tried from the above list work well while running Max 8.2 in Rosetta. When you Get Info on the Max app in the Finder, do you see that 'Open Using Rosetta' is selected?
    • Oct 14 2021 | 6:38 pm
      @BEN BRACKEN Doh. I think I must have my brain in literally backwards - I looked at that checkbox and carefully misunderstood and left it unchecked, rather than checked. After I set it as you suggested, everything is loading. There are some new error messages about faulty filepaths (can't find notfound....) , but that should be easily sortable, and multiple errors from interfacecolor.js, which I've tracked down to the old copied version of the dsp setup window that is in all of my patchers, so I just need to revise that. The list still stands (if it's useful) for running 8.2 without Rosetta. thanks