Max Patch File size - How is this possible?


    Jun 29 2017 | 2:08 pm
    Hi, this is quite a problem for me. I'm working on quite big project in Max. I'm also constantly making new versions of the patch. However recently I have done a lot of work on the last version of the patch and then something went wrong.
    So here is the story - I have made the last version of the patch which the file size was 5 MB and then I have added this patch as a bpatcher to a new patch. However it looks like that when I have added the bpatch to this new patcher the file size of the corresponding patch has grow up to a really large file of 240 MB. How is this possible?
    The main problem that I have now is that I can't open the 240 MB patch and save it, so basically my last work (and there was lot of it) is now gone.
    Obviously also the main patch in which is included the bpatcher wont work. The funny think is that this is only of 140 KB size.
    I think how ever that the 240 MB size is a bug.
    I would also like to understand more how Max handle the bpatcher in other projects does the patch that contain them just use a path to the bpatcher and is this why the patch with a large bpathcer in it, is way more smaller than the contained patch - bpatch.
    Any help would be much appreciated. I would really like to get my last work back.
    Thanks!
    Best,
    AK

    • Jun 29 2017 | 4:22 pm
      yes it is just a bpatcher object with the path to the file, not different from [poly~ foo] or [mysubpatch]
    • Jun 29 2017 | 5:22 pm
      Thanks Roman,
      I get that, but still can't understand how has turn my patch from 5 MB to 240 MB I think that this has happened presumably after I have included the patch in another patch as a bpatcher. The problem now is that now I can't get the patch back Because Max keeps crashing if I try to load it obviously because I think the patch is to big.
      Any help would be much appreciated.
    • Jun 29 2017 | 8:13 pm
      I once had a patch which suddenly was 5MB instead of a few hundred kB. The reason was that I copy-pasted a max object from some 3rd party patch, which had hundreds of styles defined. That styles multiplied in the patch somehow. I fixed that by editing the maxpat file with a text editor, removing all the styles...
    • Jun 29 2017 | 8:16 pm
      Hi, I have opened the patch in a text editor (Sublime) and I have found this really strange lines of code that looks like this - " Some accuracy lost to truncation‚Äö" and this is like thousand of it so this is what make my patch so big - 240 MB. What I would really like to understand is how this happened. So I have basically tried to remove that forever repeating code and re-open it in Max but now I get this error and the worst is so that I have still not got my patch back. Here are the errors message in console
      error parsing patcher file granular_3.4.9.maxpat
      parsing string, possible missing quote: line=137104, char=1, text='...á‚Äö√Ñ√∂‚àö‚Ć‚àö‚àǬ¨¬®‚Ä?, '
      Any help and an explanation how could this happened would be most welcome and appreciated.
      THX
    • Jun 30 2017 | 7:08 am
      Ok now I have manage to fix this with editing the text. But still I can't understand how it came to this. I have not copy pasted the patch or something I have just put it in a new patch as a bpatcher. From now on I will definitely make two version so that I can add one to bpatcher and have one as a safe copy. Anyway it would be nice if the issue could be addressed, although I think it's hard to reproduce, because now I have retried the process and it works fine.
      Thanks Roman & Hollyhook for your help.
      Best, AK