Max8 and Beats3 headphones Crashing


    Mar 03 2019 | 3:04 pm
    I got some free Beats3 headphones with my new computer. But everytime I try to connect to them Max8 instantly crashes. Anyone else have this issue?

    • Mar 04 2019 | 5:30 pm
      i've read a similar problem somewhere with apple airpods, some time ago... not sure where
    • Mar 04 2019 | 5:42 pm
      I have the same problem with BeatsX. I want to say it worked fine with Max7, but I've also switched computers since I had used my headphones with it last.
    • Mar 04 2019 | 5:47 pm
      hi everyone, the devs are aware of this issue and working on a fix.
    • Mar 04 2019 | 6:14 pm
      Excellent, thank you.
    • Apr 04 2019 | 7:12 am
      With update 8.0.4 Max has stopped crashing when changing Audio output to Bluetooth headphone (Sony W-1000XM3). However, now there is no sound output. (Works OK in Max 7)
      Anyone have an answer for this new problem?
    • Apr 04 2019 | 10:09 am
      Yes, I con confirm Wil's experience. It now doesn't crash; but there's no sound and the audio seems frozen.
    • May 15 2019 | 6:01 am
      Has this issue been fixed? I'm experiencing the same problem when changing the audio output to bluetooth headphones.
    • Jun 02 2019 | 2:33 am
      8.0.5 still not working.
      For the tech folks, this is what's happening. On MacBook 2017, not sure about PC.
      When you connect Bluetooth headphones to the computer, Sound preferences inside the Mac change from 'built in output' to '(bluetooth headphones)'.
      But Max Audio status overrides the computers system preferences, so even tough the computer is set to output the chosen headphones, Max can be set to built in output and the sound will not go to the headphones, but instead to the speakers.
      When you change max to the chosen bluetooth headphones, not only is no sound coming out, but the player isn't playing at all. In my case sfplay.
      So something in the Audio status is turning off the the sound when Max Audio status is changed to bluetooth headphones, even though the status indicator changes to blue suggesting that the Audio status is on.
    • Jun 02 2019 | 2:07 pm
      Hmmm... I can confirm, that Macs behaves somewhat himerically when I try to work with bluetooth audio devices. Maybe this is a problem related to the infamous T2 chip?
      In addition, recently I can not choose (from Mojave) "none" as audio input - which is possible on Windows.
      Another interesting phenomena is, for example, some USB cameras: if they have a microphone, they will inject themselves as audio input in Max prefs (and I can not set "none") and finally block audio processing in the patch.
    • Jun 03 2019 | 10:01 am
      YANIKI, they work fine in Max 7. So it must be Max related, not Mac.
    • Jun 12 2019 | 5:32 am
      Got this working in 806 update. Maybe worked in 805, not sure. Have to change output to ad_portaudio instead of core audio.