maxtilde_plugdevice: doesn't understand "livehascapability"

    Jan 01 2021 | 8:11 pm
    Has anyone run into this in the last few months?
    I've got a bunch of M4L devices I've built and since Max 8.1.7 (or maybe 8.1.6) I get this (red) error message when I load a bunch of them. As far as I can tell, the M4L is still working, but I'm not sure what this error message is supposed to be communicating.
    (I'm on OSX 10.14.6 / Max 8.1.8)

    • Jan 05 2021 | 8:58 pm
      Same here, what does this even means?
    • Jan 05 2021 | 9:01 pm
      I think it's a bug having to do with [live.thisdevice]. I submitted it the other day and they confirmed.
    • Jan 05 2021 | 9:11 pm
      hmm, interresting. ty!
    • Feb 02 2021 | 12:38 am
      Hey Rodrigo, I'm sorry to bother you on this unrelated thread, but I saw you had replied on another post one time about having bought the Boppad, and I'm having a similar problem with figuring out how to trigger 6 different midi notes within one quadrant. I'm not even sure if it's possible to do? I downloaded the BopPad Zones patch for max and either I can't figure it out, or this still doesn't quite accomplish what I was picturing. So I was just wondering if you were able to figure out how to do that? Or if it was even possible?
    • Feb 02 2021 | 12:43 am
      Heh, definitely better served for another thread, perhaps this one:
      But in short, I did manage to figure it out, although it's not perfect (far from). I basically set up a threshold for the velocity in each quadrant, so 0-15 = zone1, 16-30 = zone2, etc... To do this you use the boppad editor as normal to set each quadrant to a different midi note (or channel), then take that and filter out each velocity from there. I can post some code if you want, but it wouldn't be so helpful unless you copy my boppad settings exactly.
      The tricky part is that the sensitivity of the boppad is actually not that high and it tends to "stick" to certain values because of the amount of force sensitive resistors under it. Plus there are "deadzones" at the extremes, so I want to say my final zone was *only* 127, since that made up a large physical space on the boppad.
    • Feb 02 2021 | 2:09 am
      Thanks for replying, but I think I'm still not understanding something. This all may be over my head, I'm not experienced with MaxMSP really.
      The threshold you've set for the velocities was this done in Max? Or the BopPad Editor? And maybe I'm misunderstanding, but it sounds like you're then using velocity to trigger different samples?
      But Max aside, I had assumed that the 6 rows in each quadrant they have in the BopPad editor was for each radius... but whatever notes I put in those 6 rows all get triggered at once no matter where I hit within the quadrant. So I thought there was something wrong with my pad. But I guess that's not how it works? And I'm honestly just really confused by the BopPad Zones patch in max. It doesn't look like it does what I'm trying to accomplish here. Even just messing around with the settings doesn't seem to affect anything. Sorry to be wasting your time. I'd honestly be willing to pay someone to walk me through what I need to do at this point.
      And again sorry for writing on this thread, I would've sent a DM but doesn't look like you can do that on here, and I wasn't sure you'd get a notification if I wrote on that other thread.
    • Feb 02 2021 | 12:48 pm
      For the sake of future readability on the forum, I've responded in the other thread:
    • Mar 11 2021 | 10:14 am
      back to OT, i can confirm stil having this bug in max 8.1.10 and osx 10.14.6 . It seemed unimportant, thansk for confirming that @Rodrigo :)
    • Apr 01 2021 | 12:58 am
      Cool. Thanks. Was wondering what this error msg was when I was dropping some amxd in max.