s2m.wacom

    MaxMSPbugs/issues

    Lorenz Lehmann
    Jan 28 2022 | 6:26 pm
    Hi all,
    I have a question that refers to the s2m.wacom-object: I want to use the Data of the Wacom Tablet "intuos 3 PTZ-431W" in my MaxPatch with s2m.wacom. But I don't want the Wacom Tablet to move my cursor. Do you have an idea?
    I heard, there is a function named "local" or something like that but I couldn't find it.
    Thank you for any ideas!

    • volker böhm's icon
      volker böhm
      Feb 19 2022 | 9:02 am
      yes, [s2m.wacom] has a 'nopointer' message that decouples the pen movement from the system cursor. I used the Intuos 3 with the [s2m.wacom] for a long time on my old machine and it worked very reliably. Be aware, though, that the current wacom driver doesn't support the Intuos 3 anymore. You might be lucky and find an old version that still supports it and works on your machine. (version 6.3.15-3 worked for me on an intel-based mac). But there are still more troubles: Around the introduction of 'Catalina' security issues started to become a major problem. [s2m.wacom] couldn't communicate with the wacom driver anymore because automation processes, like sending Apple events, are blocked now by default. This renders messages like 'nopointer' non-functional. AFAIK this issue is still not resolved (at the moment I'm working on an updated version of [s2m.wacom] for arm64 (M1) and face the exact problem of blocked Apple events).
      Share
    • Lorenz Lehmann's icon
      Lorenz Lehmann's icon
      Lorenz Lehmann
      Feb 23 2022 | 2:56 pm
      Dear Volker Böhm,
      thanks for the very interesting and helpful information. That helped me a lot. I will now use the nopointer message that works great for me! All best, Lorenz
    • Alexandre's icon
      Alexandre's icon
      Alexandre
      May 31 2023 | 11:27 pm
      So i just dl this s2m.wacom object from https://metason.prism.cnrs.fr/Resultats/MaxMSP/ and it's loading in rosetta in max 8 ... but i didn't find any maxhelp file ... anyone have any idea for a maxhelp file? (this s2m.wacom does not have the same number of outlets than the wacom.mxo object that is not loading "due to incorrect architecture") ...EDIT: Damn, i just realised that there is not device-ID outlet on this s2m.wacom... and i use two pen at the same time (picture in my presentation alexbart.org) ...Nobody knows if there is a way to use the older wacom.mxo on Monterey on macbookpro-M1 ? 🙏
    • volker böhm's icon
      volker böhm's icon
      volker böhm
      Jun 01 2023 | 6:49 am