wacom tablet crashing standalone


    Aug 04 2020 | 8:17 pm
    Hi all I'm trying to include wacom tablet pen pressure support in my standalone app but I'm running into trouble. When building the application I click "include file" and select the s2m.wacom.mxo file from my hard drive to include it. I've also tried just leaving the s2m.wacom.mxo file in the resources folder of the standalone Both instances seem to load it fine but the app crashes as soon as the pen comes near the wacom tablet... Any ideas? Thanks in advance

    • Aug 05 2020 | 7:47 am
      MacOS restrictions ? More infos about max version, system, external itself etc could be helpful. You could also try to run standalone through terminal, by doubleclicking the binary executable in the /Contents/MacOS/ Maybe it would post errors to console
    • Aug 05 2020 | 2:15 pm
      Thank you for the terminal recommendation. It seems to work fine with run via terminal-- It asks for tablet permissions. When opened normally it doesn't do that-- Could this be some sort of permissions issue? I'm running max version 8.1.5 on Mac OS 10.15.5 Catalina
    • Aug 05 2020 | 2:59 pm
      that is allready a good sign. I am not using catalina, so can't help you with immediate answer. You might need to go to system preferences, security & privacy and there allow your standalone to control your system. or could you post exact what has been asked while running through terminal ?
    • Aug 10 2020 | 3:13 pm
      Thanks source-- Attached is the dialog box that comes up when I run the executable through terminal. I don't get the same box when I open the application normally by double clicking on the package. Any ideas how I might be able to get that to happen?
      Thanks all
    • Aug 10 2020 | 3:36 pm
      Did you check system preferences for security and assistive devices ?
      https://www.wacom.com/en-au/support?guideTitle=Setting-up-Mac-OS-security-settings-on-10.13-%26-10.12&guideId=150-433
      https://mizage.com/help/accessibility.html#10.10
    • Aug 10 2020 | 5:56 pm
      Thanks again Source-- The standalone shows up as good to go for the wacom tablet driver. I also enabled accessibility features for the standalone. Still getting that crash
      The tablet works when the patch is running in max, and when I open the standalone executable in terminal and it works for other applications like photoshop but the standalone still crashes instantly whenever I bring the pen near the tablet...
    • Aug 11 2020 | 6:31 am
      It is impossible for me to help you further without having the tablet and test myself. I could only guess that permissions to comunicate with tablet were not granted, and that it was the cause, but if it now initialises ok but crashes when used, it must be something to do with the standalone itself. Are you using max 8.1.5 ? sorry you posted that allreeady it behaves much better for issues with privileges than older versions. I had no problem to run max 8.1.5 standalones without any signing and notarization on fully protected Catalina 10.15.6 one just needs to remove any xattributes from the app before launching it. ------- Could you try to compile new version of the app, with short name, properly set standalone inspector, to use only stuff really needed using max 815 and see what happens ? ------- One problem that sometimes happens is translocation - in which case app gets executed form some temporary directory and so looses the file structure. I usually exclude all externals when building standalone, and configure them manually in app bundle. ------ If you want me to check the patch and standalone settings just upload the patch.
    • Aug 12 2020 | 3:52 pm
      Thank you again Source-- I really appreciate the help you've given me here.
      Here's the stripped-down patch -
      the external I'm using is linked here http://www.vjmanzo.com/maxobjects/index.php?v=objects&id_objet=4800
      I've removed the external from the max search path so it shows up as missing when I build the app. Then I put it back in the app contents manually in the c74/externals folder
      It isnt crashing in this scenario but it isn't working either. Strangely, it will show whether the pen is near the tablet but nothing else. I'm still scratching my head at this point. Perhaps worth noting that versions I built months ago using max 8.1.1 seem to work fine.
    • Aug 13 2020 | 8:08 am
      It is hard to say from that stripped-down patch what would be optimal standalone configuration, but you left "Max 8 Preferences" and default "com.mycompany.myprogram" bundle indentifier. That , together with probably not correctly set info.plist file could make problems to get it running.
      If you made it work using max 8.1.1, why don't you keep it ? You can run any Max 8 version at same time, just rename it to Max811. there is a message excludeexternals true which can be entered on the top of standalone build Script. That builds mxf with nothing included, beside patch as is including that bits of code that make it act as mxf. Such mxf built in max 815 can be placed into max 811 standalone. One than needs to copy externals , or use previously build standalone with C74 resources included, and then reduced to what is needed.