Standalone missing msvcp120.dll on Windows


    Sep 28 2015 | 10:43 am
    I've created a standalone. On some Windows systems runs fine, while on others my betatesters get this error of a missing MSVCP120.dll.
    Any idea?

    • Sep 29 2015 | 1:14 am
      Have they installed the relevant Visual C++ Redistributable package (if this is done in Visual Studio)?
    • Apr 15 2016 | 5:16 pm
      Re-surfacing this thread. I have a standalone that works fine on Win 7 systems, but when I try running it on a Win 10 system (32 bit), I initially get the warning about the app not being trusted or whatever, but after telling it to proceed anyway, I get errors saying that both MSVCP120.dll and MSVCR120.dll are missing.
      I tried installing the Visual C++ Redistributable package from here https://www.microsoft.com/en-us/download/details.aspx?id=48145 , with no change afterwards.
      Anyone have ideas on this? If it matters, I'm running my Win 10 instance in a Virtual Box container on a Mac OS host system.
    • Apr 16 2016 | 3:16 am
      I believe you linked/downloaded the wrong redistributable package. The two DLLs you seek indicate the executable was compiled with Visual Studio 2013 (rather than the 2015 you linked/downloaded)
      MSVCPxxx.dll and MSVCRxxx.dll where xxx == Visual Studio yyyy 100 = Visual Studio 2010 110 = Visual Studio 2012 120 = Visual Studio 2013 140 = Visual Studio 2015
      The too many clicks method to get the redistribution files you need starts at https://www.visualstudio.com/en-us/downloads/download-visual-studio-vs.aspx click Tools for Visual Studio 2013 click Visual C++ Redistributable for Visual Studio 2013 click language click format (of the executable, not your operating system) click download
    • Apr 16 2016 | 12:25 pm
      Perfect! Thank you very much, that fixed it right away, plus I appreciate both the step by step navigation of the MS web site (saved me a ton of time), as well as the background info you provided about the versions, might be helpful for the future.
      Dan
    • May 01 2016 | 6:30 pm
      i had this problem just now and while installing all versions of vc redist packages i could find i was also installing Max as a demo , on the machines i need to run the application , and i was thinking that actually installing max was the thing that fixed the problem , and now i cant check because it is all already installed... any info if i should have max installed on the user machines?
    • May 02 2016 | 12:25 am
      You shouldn't need to install the Max Demo just to get a standalone running on Windows. If you install the Visual Studio redistributable that @diablodale linked to above, that should be all that is needed (it was for me).
    • Sep 12 2016 | 9:47 am
      Hey, seems like I experience the same problem here with WIN 8.1 Standalone running on WIN 7, but error message "missing msvcp120.dll" on WIN 8.1
      HERE S THE QUESTION: Is it possible to distribute this "msvcp120.dll - file" with(in) the standalone, or do all my clients have to install it using the link neatly provided above?!
      I have no idea whatsoever this .dll thing is - all I do is Max coding ... any hints?
    • Sep 13 2016 | 9:10 pm
      FYI, When we release Max 7.2.5 the runtime DLL dependency will be taken care of for objects compiled with Visual Studio 2015.
    • Apr 25 2018 | 6:44 am
      Hi all, is there a list of objects "compiled with Visual Studio"? because I'm having same problem of this thread now, and I would prefer to remove these objects instead of ask my users to install extra software... thanks
    • May 08 2018 | 9:06 am
      Hi all, is there a list of objects "compiled with Visual Studio"? because I'm having same problem of this thread now, and I would prefer to remove these objects instead of ask my users to install extra software... thanks
      A list would be great! We also have exactly the same problem! Also with VCRUNTIME140D.dll and ucrtbased.dll
    • May 14 2018 | 9:07 pm
      140D indicates that the externals are debug builds, built against the Microsoft debug libraries instead of the release libraries. The developers of those externals should compile again as release builds.
      I'm not sure how you would get a list of these objects. If you find certain objects to be problematic perhaps list them on this thread and we can try to work with the developers to update their builds.
      Cheers!
    • May 15 2018 | 6:08 am
      Hi Timothy and all, hi had just a 120 dependancy, and i used a quite basic set of standard max objects. Is there some standard max object that needs Visual Studio library? How can I discover them?? thanks!
    • May 15 2018 | 2:38 pm
      @fcana Can you open your patcher in Max, then go to the File menu and choose "List Externals and Subpatcher Files"?
      If you paste that list in here we might be able to spot any culprits.
    • May 16 2018 | 5:20 am
      Hi, thank you very much here the list: Max Object rminus.mxo Max Object *.mxo Max Object +.mxo MSP64 Object plus~.mxo Max Object -.mxo Max Object adstatus.mxo Max Object bgcolor.mxo MSP64 Object biquad~.mxo Max Object bondo.mxo Max Object buddy.mxo Max Object button.mxo Max Object comment.mxo MSP64 Object cross~.mxo MSP64 Object curve~.mxo MSP64 Object cycle~.mxo Max Object dbtoa.mxo Max Object delay.mxo MSP64 Object dspstate~.mxo Max Object expr.mxo MSP64 Object ezdac~.mxo MSP64 Object filtercoeff~.mxo Max Object fpic.mxo MSP64 Object gen~.mxo Max Object history.mxo Max Object in.mxo Max Object int.mxo Max Object js.mxo Max Object kslider.mxo Max Object led.mxo MSP64 Object live.gain~.mxo Max Object live.guilib.mxo Max Object live.guilib.mxo Max Object live.guilib.mxo Max Object loadmess.mxo Max Object makenote.mxo Max Object message.mxo Max Object metro.mxo Max Object midiflush.mxo Max Object mix.mxo Max Object mtof.mxo Max Object number.mxo Max Object out.mxo MSP64 Object out~.mxo Max Object pak.mxo Max Object panel.mxo Max Object param.mxo Max Object pipe.mxo MSP64 Object poly~.mxo Max Object prepend.mxo Max Object scale.mxo MSP64 Object scale~.mxo Max Object speedlim.mxo Max Object spray.mxo Max Object standalone.mxo Max Object substitute.mxo Max Object textbutton.mxo MSP64 Object thispoly~.mxo MSP64 Object times~.mxo Max Object toggle.mxo Max Object ubutton.mxo Max Object umenu.mxo Max Object universal.mxo Max Object uzi.mxo Max Object zl.mxo
    • May 16 2018 | 1:15 pm
      Hmmm... These are all stock objects! Not sure what is going on. Can you please send your built standalone to support@cycling74.com so we can try and figure this out?
      Thanks!
    • May 16 2018 | 2:09 pm
      never heard of param.mxo and mix.mxo, besides that mxo is mac format...
    • May 16 2018 | 4:55 pm
      @timoty place: ok, done! @source audio: these are gen~ objects
    • May 16 2018 | 6:01 pm
      Okay, the authoritative answer on this subject is below. It is a bummer to have to tell users of the standalone to install this. One option is to try an make an installer that installs it as a part of it's process.
      Max depends on the Microsoft C Runtime Library. To use a standalone on a computer that has not run the Max installer or the Max installer you must first run the Microsoft Visual C++ 2013 Redistributable Package . This can be downloaded from Microsoft. An alternative is to simply download and install Max. The Microsoft redistributable files can be found at this URL:
    • May 16 2018 | 7:41 pm
      One option is to try an make an installer that installs it as a part of it's process.
      Hi Timothy, unfortunately I'm completely new to this... never created an installer. do you have some tool or something to advice me before i had to google for a month ;)?? best
    • May 16 2018 | 8:18 pm
      another option: I tried to add the dll files in app root folder... it works smoothly. maybe it's not a so right way to distribute the Redistributable Package... but, what do you think?
    • May 16 2018 | 8:32 pm
      Great idea! If it works, and if there is nothing in the license of the Redistributable Package to prohibit it, then I'd be inclined to do it :-)
      I'll see if someone on our engineering team has any additional insight.
    • May 16 2018 | 10:30 pm
      That's the exact approach I've been using for years now - just put the .dll's in the same folder as the .exe .
      I go one step further actually, and use a utility called Enigma Virtual Box that packages all of the "extra" stuff required on Windows (including these .dll's, the .mxf file, etc...), and makes it appear like one regular .exe to the end user, hiding all of the other files. But that's another discussion. ;-) See the following thread for more details (the relevant info is towards the middle of the thread)! https://cycling74.com/forums/fyi-successfully-protected-a-standalone-max-app-on-pc
    • Oct 19 2018 | 4:04 pm
      Dan, that is pretty awesome. I've used some protection stuff from EXCEL SOFTWARE over the years. They charge an arm and a leg and it barely worked. I just made my own method native to max and was surprised to see it not working on PC. This DLL issue definitely DEFINITELY needs to be sorted out asap!
      Do you really like the Enigma Stuff? Anything like it for Mac? Thank you everyone
    • Oct 19 2018 | 4:07 pm
      Not ever found anything like Enigma Virtual Box for Mac, but honestly it's not that necessary, since the application is "bundled" on the Mac, so a single file contains everything.
    • Oct 22 2018 | 10:27 am
      Dan,
      since you have experience with all the DLLs can you list Your process of how you retrieve all the necessary DLLs (and which ones ) in order to avoid this problem on all windows platforms?
      little confused by this. Thanks
    • Oct 22 2018 | 11:40 am
      Diablodale lists some very helpful info above:
      MSVCPxxx.dll and MSVCRxxx.dll where xxx == Visual Studio yyyy 100 = Visual Studio 2010 110 = Visual Studio 2012 120 = Visual Studio 2013 140 = Visual Studio 2015
      For recent versions of Max (i.e. 7 and 8), I've found that what's needed are the Visual Studio 2013 versions, or the "120" ones. Unfortunately the direct link he provided no longer works, but the one that Tim Place provided above does: https://www.microsoft.com/en-us/download/details.aspx?id=40784 Once you get the files, just copy MSVCP120.dll and MSVCR120.dll and place them in the same directory as your standalone .exe file. Hope that helps.
    • Oct 22 2018 | 12:07 pm
      Is it really necessary to install VC 2010-15? I just built a standalone with the latest Max8. When testing it on 2 other PCs i got the error for MSVCP140.dll and VCRUNTIME140.dll (is this the same as MSVCR?) are both missing.
      Thanks
    • Oct 22 2018 | 12:45 pm
      That's news to me (the need for the 140 files), but possible I guess. First I've ever seen a message about VCRUNTIME though, no idea if it's the same as MSVCR....
    • Oct 22 2018 | 12:48 pm
      Also worth mentioning that the dependency on the 140 files might be caused by a 3rd party external you're using (as opposed to built in Max objects)?