Unable to build app (solved)

    Apr 10 2019 | 11:22 am
    I'm unable to build an app/collective, either from the file menu or from within the project itself. I click, nothing happens - Max window says "Succesfully built project to application" but no such file can be found. I've tried updating Max, re-starting, saving to different directories, but nothing. It was working fine last time I tried, but this morning when I tried to build the app, Max crashed (crashlog attached) - I thought I had traced the problem to the app trying to load a dodgy plug-in, so I reverted to an older version of the patch, and this at least stopped Max crashing on start-up. However since then I've been unable to build an app or collective - help! Help desperately sought as I was hoping to put this up onto the Apps Store soon... (Max 8.0.5, OS 10.13.6, 15" 2012 MacBook Pro)

    • Apr 16 2019 | 9:09 am
      Bump. I would really appreciate some help. TIA
    • Apr 16 2019 | 10:10 am
      Sorry to hear You still have trouble with that. I would take all parts (patches, subpatches, media & whatever else) belonging to that project out of wherever they reside, and place in some new created folder OUT OF Max search path. Then delete all max preferences, temporary files and such. Second disable autorestore at launch or any other automatic actions from Max side. Then try to build Standalone into some new location, preferably in User domain, like for example desktop, just to make sure there are no issues with privileges or similar.
      Let's first see if that helps, and if not, one could try other things maybe
    • Apr 17 2019 | 12:19 pm
      Thanks for your reply.
      The main patch in the project is already outside the Max search path - it uses a trick from this thread to determine the path, so that I could work on it knowing that dependent files would be found relative to the app when it was finished, and this has worked well so far (with the one exception that it won't work with Dropbox). I did also try building to different locations such as the Desktop. However, I have now managed to get it working again simply by creating a new Project and dragging the main patch into it etc.
    • Apr 17 2019 | 4:10 pm
      ...I may have spoken too soon. I can build the app now, but when I run it, I'm getting a problem which wasn't there before; There is a part of patcher which displays images in jweb via the 'readfile' message, and it works fine as a patcher, and was working as an app, but now it no longer works. It can load urls from the web but the only image it is able to display using readfile is one that has already been included in the project, i.e it will not display files loaded from the Finder.
      I have been unable to reproduce the problem by isolating the part of the patcher that uses jweb, but if I try to build the whole patch the problem persists.
      The only error in the Max window that I guess could be relevant is "error locating jitter-passes folder".
    • Apr 17 2019 | 5:04 pm
      I am on the run, have just enough time to say:
      I had similar problems with jweb, solved them by creating new instance of jweb with scripting, and also forcing it to front.
      More infos in 2 days when I get back home
    • Apr 18 2019 | 11:43 am
      This gets worse... The patch/app uses two folders that are kept at the same level as the patch to store audio files and image files that can be loaded via umenus. This morning I find these folders have been emptied and all the contents transferred to a folder called Media within the project folder - is this the expected behaviour? Is there a way to continue work on this as Project but not have this happen?
    • Apr 18 2019 | 2:38 pm
      Still on the run, just peeked in. Having Max take care of what should be copied / included etc in a Project is maybe a nice idea but I would never rely on that.
      Make hard path link to both folders in use. here one example, taking care of Max or Standalone path difference when searching for the folders.
    • Apr 18 2019 | 3:04 pm
      Thanks. Yes, my patch does something similar and it was all working fine whilst I was working on the patch from within it's own folder, which, as I say, was on the Desktop. What's weird is that the Project window was happy to work with the patcher with it in that location until recently, when suddenly it wouldn't work unless the patcher was in the /Projects/Patchers folder. This meant I had to copy my other two media folders (one for audio, one for images) into the same directory, because the search path was relative to the patcher/app. But then it appears that Max arbitrarily moved all the stuff out of those folders into the Projects/media folder, thereby breaking things. Maybe I don't quite get how Projects are supposed to work, but I'm starting to think they're not quite the panacea for app building I'd hoped for. For now, I've dumped everything back onto the folder on the Desktop, and I'll build things the old skool way...
    • Apr 25 2019 | 9:34 am
      So the culprit was an unchecked CEF Support in Standalone. Curious though that jweb was still able to parse web pages, but not to display local files, and that in various stages of troubleshooting it was crashing/not crashing but unable to display any images/able to display images but not at the correct resolution etc.
    • Sep 06 2020 | 9:04 am
      Dear all,
      For information: I just encountered the same problem than Roger Carruthers with the main patch of a project not successfully built as standalone/collective although the console says the opposite.
      The reason of this was, at least for me, that I disabled the automatic patch opening on project load. When I put it back building finally worked. I guess this can be considered as a bug.
      Best regards,