Jit.grab not working in standalone


    Jul 09 2018 | 5:27 pm
    I'm having trouble getting output from jit.grab in a standalone; it works fine as a patch in Max, and it was working as a standalone in an earlier iteration of this patch, but now I'm getting nothing, i.e. the iSight light is not coming on, and the pwindow remains black.
    The capture part of the patch is not much more than the jit.grab.help file. I'm using the QT engine because i was having performance issues recording with avf. Any ideas? I've tried various options in the standalone object but nothing seems to helping.
    Whilst I'm here, another observation (bug?) with jit.grab - if Max is open when I shut down my Mac, next time I reboot jit.grab only shows DV Video and IIDC Firewire as the only options for vdev, even if I refresh the menus, so I get no output (incidentally, the same thing happens if I check copysupport in Standalone). Quitting re-booting Max returns the FaceTime HD option.

    • Jul 14 2018 | 3:54 pm
      So I've established that I can get capture working in a standalone if I change the engine back to afv - the trouble is, it looks like pixelated crap. The capture is quite presentable using the qt engine, but unfortunately I get no capture as soon as I turn it into a standalone. Any idea why this should be? I'm using the built-in iSight on a Mid 2012 15" MacBook Pro, running Max 7.3.5 and OS10.13.5
      Your help would be hugely appreciated. Really.
      I say that because I just checked, and the last 8 queries that I have posted here have received precisely zero replies. I'm beginning to wonder if I smell, or something... I've been a member of the Max community since 1998, and I'd like to believe that the questions I've been asking are not completely stupid, though please feel free to let me know if I'm wrong. It would be better than being ignored, y'know...
    • Jul 14 2018 | 7:37 pm
      check my reply here for how to fix the low resolution jit.grab output with avf engine: https://cycling74.com/forums/jit-grab-resolution
      i would not recommend using qt engine unless there's a specific reason to.
    • Jul 14 2018 | 10:20 pm
      At last - thank you so much!