Max Patcher not opening anymore - solved


    Apr 26 2017 | 12:04 am
    Hi guys,
    A patcher I've been working on for some weeks has bugged out on me and now won't open at all. It progressed from opening normally yesterday, to this morning only opening a couple of the sub-patchers but not the main patcher window. I could still get to the main patcher via the patcher windows button, so I closed all the sub windows and saved with just the main patcher open. I closed/re-opened Max to find no patcher windows opening now, but the usual initialisation messages still coming up in the Max console. I tried closing/re-opening Max again and now I'm getting nothing. I compared the text with a working patcher and can't find anything noticeably weird... Anyone have any insights?
    Max 7, Windows 10, x64
    -Nick

    • Apr 26 2017 | 12:31 am
      Ok, so I solve my own issue 15min after asking for help, but I'll put the steps here for anyone with the same issue.
      File > Open As Text on the dodgy patcher and Copy All
      File > New From Clipboard got me into the patcher again, and I saved it as a new file
      This got the patcher open again so I could see where the problem lay.
      One of my most recent changes was trying to feed cv.jit.faces a 'read' message (via a loadbang) of a different face recognition model from a path to a new xml. I deleted the loadbang, closed/re-opened and everything is back to normal!
      So, it looks like cv.jit.faces has issues with taking new models with the read message. Or perhaps just new ones (I was trying out the relatively new lbpcascade_frontalface_improved.xml from the OpenCV git). Looks like I'm going back to the stock haarFaceCascade1.xml!
      Hope this helps anyone with a similar problem!
    • Apr 26 2017 | 8:20 am
      the problem often lies in initalisation-related things.
      in case you dont know: you can also open patches with loadbang disabled by holding alt
    • Sep 14 2017 | 4:59 am
      Thanks for that Roman, I didn't know about holding alt on opening. That's super useful!