Mira.multitouch under ARM could not load due to 'incorrect architecture'

    Feb 17 2022 | 7:18 pm
    I'm using Max on an M1 Mac and the mira.multitouch object doesn't load unless I run Max using Rosetta. Is there any official info on the matter? I've tried following the steps in this article but to no avail.
    Alternatively, is there a guide on how to completely uninstall Max on Mac and making a fresh install?

    • Feb 17 2022 | 7:30 pm
      Just download the latest (Max 8.2.2) here. You can just install over top of your previous install. Mira has been M1-native compatible since Max 8.2.0.
    • Feb 17 2022 | 7:42 pm
      Well, that's what I already did. Still, when opening a new patcher, mira.multitouch does not load. I'll try performing a clean install...
    • Feb 17 2022 | 7:46 pm
      @GORAN Maybe you have another version of mira.multitouch in your search path? Are you working from a Project or a Max for Live device that perhaps contains an old external? Drop a note to Support if you are still having problems.
    • Feb 17 2022 | 10:21 pm
      Solved! Turns out I had a Max patch in ~/Documents/Max 8/Library that contained an outdated external. After deleting it and following the instructions in the aforementioned article, it now loads ok. Thanks a lot!